Please or Register to create posts and topics.

SOLVED: Sweep frequencies are incorrect

I'm new, so hopefully I'm doing something wrong. I'm using DefaultSweepMission with an RSA-250X. I have it connected to a SignalHound VSG60 signal generator through a power splitter with a BB60C. I'm generating a -40dBm tone at 750MHz.

  • In sweep mode, the tone appears on the waterfall at 712MHz.
  • In fsweep mode, it appears at 675MHz.
  • In scan mode, it appears at 680MHz, although there are tons of intermittent duplicates elsewhere.
  • In realtime mode, it appears at 737.25MHz (and 921.75, 829.5MHz, and pretty much anywhere I put the center freq)

I can't find documentation on what these modes do (please point it out to me if you have it), but presumably they should all show an accurate frequency?

I've also generated the tone at 1GHz with similar strange offsets.

See attached file for an example of sweep mode in RTSA. I've also attached an image from the BB60C from the same time.

Uploaded files:
  • sweep-example.png
  • sh-screen1.png

I don't see why this should be the case.

Works perfectly with the default missions and a R&S SMA100A feeding directly to the SPECTRAN V6:

Perfect Image Rejection


Same in Real-Time mode:

Real-Time Spectrum


I think you should check your test setup since it is quite clear from your screenshot that your test signal seems to be no CW signal but a somehow modulated something (check your waterfall view, it is no stable signal).

Your splitter setup might also cause some unwanted images coming from undamped feeds (did you add attenuators to all paths?) or feedback from the other units within the path. They might generate some unwanted signals - hard to say.

From your screenshot I also see a warning sign in the SPECTRAN V6 block. You should check if you have a problem there...

And last but not least you might have an faulty FPGA code in the SPECTRAN V6 (but this is quite impossible).

Update to the latest build just to be sure.

For further documentation on the SPECTRAN V6 Sweep Zoom block please have a look at

I believe I have resolved the issue for myself, but I can continue to reproduce these errors at will in two different setups.

  1. Connecting through a USB 2.0 port. I'm guessing tuning commands or sweep results are dropped between the RSA and the host resulting in these weird tuning artifacts. Is it possible your tuning commands or sweep results have relative frequencies? So if one packet is dropped, the relative values are invalid?
  2. Connecting through a USB 3.0 hub (SABRENT) produces similar artifacts.

Note my setup was as described--the signal was not modulated in any way, it was a simple CW tone. The "modulated" artifact you saw at the correct frequency was solely your software.

I've not yet been able to reproduce it with a direct-to-the-motherboard USB 3.0 port. If this reoccurs, I'll let you know.

OK good so it's solved as USB 2.0 just can't handle the data throughput required, same problem with the hub used.

It might be possible to get that hub running in the future:

But surely this problem appeared in the SPECTRAN V6 block, that's why you got the alarm sign and certainly a notification in the USB display (yellow color).