Please or Register to create posts and topics.

Linux: RTSA-Suite PRO Qt error on launch

Good afternoon,

I've installed RTSA Suite PRO in Ubuntu 22.04.2 LTS by following the tutorial at, the only differences being that I didn't do the optional step and that I used the installer inside the usb stick provided with the SDR. The installation seemed to go well, but when I tried to launch the application Aaronia/RTSA/Aaronia-RTSA-Suite-PRO/Aaronia-RTSA-Suite-PRO (which I supposed is what launches the application) I got the error:

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found

I've tried reinstalling multiple times, executing the sh file instead of the application and adding the directory plugins to $PATH, but the result is the same.

To solve this just run:

sudo apt-get install libxcb-xinerama0

Hello, thank you for the quick answer. Unfortunately, I still get the same error. Is there any aditional information I can provide?

Then you're probably not starting the RTSA using the .sh script.
Can you please start it using the .sh and paste the output here. The should also be a desktop shortcut, that uses the correct paths.

Also, please use the installer version provided on our website: - I don't know how old your USB stick actually is.

As you said, I wasn't using the sh nor the desktop shortcut. Both work fine, thank you. I'll keep the installer in mind if I ever need to reinstall the application.

fw_dev has reacted to this post.