Please or Register to create posts and topics.

Rf chamber leakage testing

I am testing leakage of RF Chamber. Inside chamber there are tranmit antenna and signal generator. Outside chamber there are receive antenna and Aaronia Spectrum Analyzer (RSA250X). When the chamber door is open RSA250X, the signal is received (as can be see in the attachment, Pic 1), however, when the chamber door is closed then there is no signal (as can see in the attachment, Pic 2). The experiment is performed on different frequencies but no luck.

Tried with other commericial Spectrum Analyzer for verification, the signal is received. Only facing problem when using RSA250x.

Do you know how can this problem can be solved? What is the sensitivity of RSA250x?

Need your kind help in this regard.

Uploaded files:
  • Screenshot-2022-07-28-135411-Pic-1.png
  • Screenshot-2022-07-28-135510-Pic-2.png

You seem to have activated both amplifier stages but you didn't lower the RefLevel to -60dBm since the control is not visible.

BTW: Use a better screen resolution.

The sensitivity is far better than any other analyzer on the market (-170dBm(Hz)).

You are also using the wrong mode: Sweep with small span. This makes no sense. Switch to real-time mode.


Thank you for your support. Now I can get the signal after changing the settings.

I am wondring the signal level with Preamp and without it. The signal level changed drastically from -40.7 to -87 dBm as you can see in the attached file. Why this is happening? Is preamp is broken? Because only the noise level needs to change not the amplitude.

Need your kind help.

Uploaded files:

Might be a software bug since you are using a very old software.

Please update to the latest version and don't use the Sweep Zoom block since it is of no use in your case..

I have connected directly an RF cable between Aaronia and signal generator. The generator power level is -50dBm. When I check the power level in Aaronia when Amplifier is disable then I can see the signal power level is -50dBm. When Amp is  ONN then still the power level is -50dBm. However, when I change the settings to preamp then the amplitude level goes down and shows -90dBm. You can also see these results in the attached file.

Is preamp not working?

Uploaded files:

Yeah looks like the preamp is fried.

If using signal generators it's better to use a 10-20dB attenuator to prevent killing the preamp...

What I need to do that in this case? Do I need to send it back to factory for repairing?



Yes. Please contact our sales department for details.