Please or Register to create posts and topics.

"Frontend FPGA Chip ID wrong message" at FPGA update

Right off the bat this unit will not upgrade FPGA. It tried on first load and has failed since.

Frontend FPGA Chip ID wrong message


This might happen if your power voltage is to low (e.g. using power banks).

Please try again using our power supply connected to the USB power port of the SPECTRAN V6.

RitaT has reacted to this post.

We faced exactly the same issue.

We are working on Spectran XRF Pro outdoor system.

Product: Aaronia RTSA-Suite PRO
BuildDate: 2022.2.1
Path: C:/Program Files/Aaronia AG/Aaronia RTSA-Suite PRO/Aaronia-RTSA-Suite-PRO.exe
Args: C:\Program Files\Aaronia AG\Aaronia RTSA-Suite PRO\Aaronia-RTSA-Suite-PRO.exe
BuildAbi: x86_64-little_endian-llp64
BuildCpuArchitecture: x86_64
CurrentCpuArchitecture: x86_64
KernelType: winnt
KernelVersion: 10.0.19042
PrettyProductName: Windows 10 Version 2009
ProductType: windows
ProductVersion: 10
primaryScreen: \\.\DISPLAY1
Screen: : \\.\DISPLAY1 Geo: 0;0;1536;864 PixRatio: 1.25 Phys.Size: 344;193 ColDepth: 32
GPUs: 3
GPU.ActiveIndex: 0
GPU.0.VendorID: 0x10de
GPU.0.VendorName: NVIDIA
GPU.0.DeviceID: 0x139a
GPU.1.VendorID: 0x8086
GPU.1.VendorName: Intel
GPU.1.DeviceID: 0x416
GPU.2.VendorID: 0x1414
GPU.2.VendorName: Microsoft Basic Render Driver
GPU.2.DeviceID: 0x8c
GPU.2.Driver: 10.0.19041.546
app path: C:/Program Files/Aaronia AG/Aaronia RTSA-Suite PRO
ddata path: C:/Users/User/Documents/Aaronia AG/Aaronia RTSA-Suite PRO
udata path: C:/Users/User/AppData/Roaming/Aaronia AG/Aaronia RTSA-Suite PRO
gdata path: C:/ProgramData/Aaronia AG/Aaronia RTSA-Suite PRO
cdata path: C:/Program Files/Aaronia AG/Aaronia RTSA-Suite PRO/cdata
LastAppStartFailed: 0
LastAppShutdownFailed: 0
WatchDogTerminatedApp: 0
InteractiveGUI: Yes
MemoryLoad: 37 %
TotalPhys: 7978 MB
AvailPhys: 4989 MB
TotalPageFile: 9258 MB
AvailPageFile: 6279 MB
TotalVirtual: 134217727 MB
AvailVirtual: 134212834 MB
Packages: 143
Licenses: 1
License: 04808022-11081044-00a056f8-8d0000a0 - Spectran_V6_A3-x-91000015.xxaaaxaa ( Auth: 0 )
Features: 4
Feature: 04808022-11081044-00a056f8-8d0000a0 - Device_Spectran_V6_InputRX2 ( Auth: 0 )
Feature: 04808022-11081044-00a056f8-8d0000a0 - Device_Spectran_V6_ReceiverClock12288 ( Auth: 0 )
Feature: 04808022-11081044-00a056f8-8d0000a0 - Device_Spectran_V6_OutputTX ( Auth: 0 )
Feature: 04808022-11081044-00a056f8-8d0000a0 - Device_Spectran_V6_ReceiverClock18432 ( Auth: 0 )

error screenshot

Is it possible to fix the problem by ourselves?

And if yes, how?

Thanks in advance.


Do you get the same error message if you update the RF FPGA?

For updating the RF FPGA you need to connect BOTH USB ports to you PC.

"Frontend FPGA Chip ID wrong" means, that the Spectran V6 can not read the FPGAs Chip ID on the Frontend Board; which is the RF FPGA.


I have fixed this and thank you for help.
The issue was with non-USB 3.0 as secondary boost connection, when upgrading the wireless FGPA the software would fail and have watchdog error.  So the Wireless FGPA was in a bad state.
I used my better, personal laptop and got two USB3.0 connections, the Wireless FGPA upgraded seamlessly and the unit started working correctly.

I'm getting a slightly different error message when also trying to Update FPGA of the V6: "Cannot load service USB firmware", as well as the "Block Spectran V6 in critical state" messages. Any ideas? I have verified that I am using all USB3.0 connections. This is also the first time setup of RTSA and this Spectran V6 unit.

Quote from CorNicWest on 24/06/2022, 10:13

I'm getting a slightly different error message when also trying to Update FPGA of the V6: "Cannot load service USB firmware",

That particular error message is triggered when you attempt to update the FPGA, but no device has been selected in the "Device Manager" config section.