Please or Register to create posts and topics.

FIXED: FileWriter/Qt crashes on Linux

Hi forum,

We are running on Ubuntu 22.04 and the Aaronia RTSA Suite PRO crashes when we try to write samples to .rtsa files.

The program crashes no matter whether we run 1 channel, 2 channels and/or 92 or 122MHz.

The program seems to crash after finishing writing a complete log file. It happens after about 1-8 logfiles (varies).

We write in 5 second chunks, these are about 500MB in size. We have tried with different compression rate (including compression off) - we still see crashes.

We have tried writing to internal SSD, external SSD and ramdisk - it crashes the same way no matter the configuration. It crashes quite quickly on internal drive and ramdisk. We got more chunks written on the external drive but it crashed within the first minute of recording.

When we run without starting the FileWriter it does not crash. Our spectrograms show nicely on screen and we can run with both channels no problem. (but we can't save to disk)

Ubuntu dmesg says:

[745.446203] DSPStreamFileWr[4183]: segfault at 8 ip 00007f60253d065d sp 00007f5efd7fc880 error 4 in[7f6025200000+5e4000]
[ 745.446225] Code: ff 66 90 66 2e 0f 1f 84 00 00 00 00 00 48 8b 47 08 0f b6 80 b8 00 00 00 c3 0f 1f 40 00 41 55 41 54 55 53 48 89 fd 48 83 ec 18 <48> 8b 5f 08 8b 43 58 a8 02 75 30 85 c0 0f 84 e0 00 00 00 48 8d 15

I have attached the files from the crash tool plus the log and logDebug logs from the "udata" directory.

We have tried with the official build and with a nightly build we received recently

Both versions crash in the same way.

We have followed the installation guidelines except we have not enabled CMA (this was optional). (CMA is for high sample rates and channel count, we crash using only 1 channel and the lowest sample rate possible (92Mhz))

Any thoughts/help?



Uploaded files:

Thank you for your detailed report. I can confirm that we can reproduce the segfault using your mission from the We'll fix it and come back to you as soon as it is fixed.

jnee has reacted to this post.

Fixed in latest nightly build.

jnee has reacted to this post.


Can we get a link to that build? (on the download page there is only a link to last stable build)



You can request a nightly build via [email protected]

jnee has reacted to this post.